Cloudflare outage
Incident Report for NamePros
Resolved
Cloudflare is gradually restoring service to all affected regions. We’re starting to see traffic to our servers return to normal levels.
Posted Jun 21, 2022 - 07:22 UTC
Investigating
NamePros is currently down in many regions due to a Cloudflare outage: https://www.cloudflarestatus.com/incidents/xvs51y9qs9dj
Posted Jun 21, 2022 - 07:02 UTC
This incident affected: Forums, Blog, RSS feed and Global network (Cloudflare).